Console, API and Auth outage on Ibexa cloud
Incident Report for Platform.sh
Postmortem

What happened

A recent failed deployment to the Ibexa admin project led to containers being unable to open.
This is directly responsible for the console, API and Auth sub-systems outage on Ibexa cloud.

This incident did not affect live environments on Grid or Dedicated infrastructure.

After our further review, our engineers have also identified that a known bug within the deployment service was responsible for the above failure.
A fix has been implemented earlier and we are working on scheduling the release of the fix globally.

How long customers were impacted

From 2023-11-08 06:10 UTC to 06:47 UTC, 37 minutes in total.

How many customers were impacted

All Ibexa customers were unable to access console or conduct any deployments during the impact period.

What was done to resolve the incident

Our team quickly re-opened / restarted the affected containers and made them available again.
Console, API and Auth sub-systems outage on Ibexa cloud are now resolved.

Posted Nov 09, 2023 - 03:22 UTC

Resolved
We have detected an issue affecting Console, API and Auth systems on Ibexa cloud after a recent failed deployment since 2023-11-08 21:10 UTC.

This outage does not affect Dedicated Enterprise Clusters nor your environments.

Our Operations team has been notified and corrected the issue by restarting the services since 2023-11-08 21:47 UTC.

A fix for this known issue has been implemented, and this will be released in the future.
Posted Nov 08, 2023 - 21:00 UTC