Performance looks to have improved recently, and we are monitoring the results.
Posted Oct 20, 2025 - 19:20 UTC
Update
We are also detecting degraded performance on the us-2.platform.sh region due to the ongoing AWS incident in us-east-1.
Currently, both us-2.platform.sh and us.platform.sh regions are impacted by degraded performance due to the ongoing AWS incident.
Posted Oct 20, 2025 - 17:02 UTC
Identified
The us.platform.sh region is continuing to experience degraded performance due to the ongoing AWS incident in us-east-1.
Posted Oct 20, 2025 - 15:55 UTC
Investigating
Our monitoring has detected serious issues with our cloud infrastructure provider which affect all sites hosted on the us.platform.sh region. Currently, these issues look to be resulting in degraded performance, rather than a complete outage.
Our operations team has been notified and they are investigating the issue with our provider.
We will update you as soon as we have further information.
Posted Oct 20, 2025 - 15:01 UTC
This incident affected: USA (East) (us.platform.sh) and USA-2 (East 2) (us-2.platform.sh).