Partial Outage on eu-2.platform.sh
Incident Report for Platform.sh
Postmortem

WHAT HAPPENED

Environments were in unexpected states during the planned maintenance event for region eu-2.platform.sh
https://status.platform.sh/incidents/97ls23652mws

Affected environments including live sites were not available for use during the incident,
this also includes functionalities like SSH accesses / deployments.

Dedicated clusters were NOT affected by this incident.

CUSTOMER IMPACT

Some customers' environments were not available for up to 9 hrs and 12 minutes in total.
(Worst case estimate for all live & non-live environments)

Start: 2024-04-24 21:50 UTC
End: 2024-04-25 07:02 UTC

WHAT WAS DONE TO RESOLVE THE INCIDENT

The unexpected states had been corrected by our engineers and now the environments should function as expected.
Our engineering team will also be investigating a potential internal bug responsible for those unexpected states causing this incident.

We will be improving the internal subsystems in order to minimize the negative impact from these planned maintenance events in the future.

Posted Apr 25, 2024 - 07:56 UTC

Resolved
Our engineers have deployed a fix to correct the issues.

All environments in this region should now function as expected.
Posted Apr 25, 2024 - 07:33 UTC
Update
All live / default environments should now function as expected.
Posted Apr 25, 2024 - 04:40 UTC
Identified
We have detected an issue affecting service on the eu-2.platform.sh region.

Our Operations team has been notified and is currently working to restore service.
Projects on affected regions may experience outages.

We will update you as soon as we have further information.
Posted Apr 25, 2024 - 04:12 UTC
This incident affected: Europe (West 2) (eu-2.platform.sh).