Partial Outage on us-3

Incident Report for Platform.sh

Postmortem

What happened

Our monitoring systems have detected slow heartbeat responses from several storage nodes.

Initial analysis shown network latency or disk I/O contention on specific nodes. This incident did not affect Dedicated infrastructure.

Customer Impact

Customer Impact was between 08:20 and 09:00 A.M UTC at 2025-05-16.

Some live sites in the affected region experienced an outage and customers were unable to access console or conduct any deployments.

What was done to resolve the incident

The storage back-end healed itself.

Posted May 16, 2025 - 12:08 UTC

Resolved

This incident has been resolved.
Posted May 16, 2025 - 11:29 UTC

Monitoring

Our systems are now stable and we are continuously monitoring it.
Posted May 16, 2025 - 10:45 UTC

Identified

The issue has been identified and Engineering team is working on it.
Posted May 16, 2025 - 09:22 UTC

Update

We have detected an issue affecting service on the US-3 regions. Our Operations team has been notified and is currently working to restore service. Projects on affected regions may experience downtime or slowness.

We will update you as soon as we have further information.
Posted May 16, 2025 - 09:11 UTC

Investigating

We identified partial outage on our US-3 Grid projects.
Posted May 16, 2025 - 09:07 UTC
This incident affected: USA-3 (West 2) (us-3.platform.sh).